1

Thema: Spezifischer Fehler mit dem Befehlseditor

Hallo liebes Dragon-Forum! Mein Name ist Johannes und ich habe ein recht eigenartiges Problem auf das ich mir ehrlich gesagt keinen Reim machen kann. Zunächst aber erkläre ich den Hergang um eventuell für eine bessere Problemfindung zu sorgen.

Ich nutzte unter Windows 10 jahrelang das Dragon Naturallyspeaking 11,5 Pro (DNS 11 Pro) ohne Probleme. Vor etwa einem Monat installierte ich dann das "Creators Fall Update" für Windows 10, welches ebenfalls ohne Probleme verlief, zunächst. Denn nach der Installation des Updates bekam mein System unregelmäßige freezes, so das ich immer wieder mal den Reset-Knopf am Rechner betätigen musste. Diesbezüglich hab ich dann logischerweise eine Lösung gesucht und auch gefunden. Mir wurde angeraten den "Standardmäßigen SATA AHCI Controller" nochmals vom Windows zu installieren. Hat auch geklappt und danach kamen auch keine freezes mehr, allerdings lies sich DNS 11 nicht mehr starten. Weshalb ich DNS 11 mit dem Remover Tool deinstallierte, was wunderbar funktioniert hat.

Ich dachte mir dann, ob es nicht Zeit wäre mir DNS 15 Pro zu kaufen, habe ich dann auch gemacht. DNS 15 normal installiert (extra auf C) und es startet auch ganz normal. Ebenso verlief die Profilerstellung ohne Probleme. Doch nun komm ich zum eigentlichen Fehler mit DNS 15.

Es ist nämlich so: Ich kann eigentlich alles machen, Diktieren, Befehle usw. Ich kann auch das "Befehlscenter" öffnen, jedoch, wenn ich den "Befehlseditor" öffnen möchte stürzt DNS 15 einfach ab, ohne Fehlermeldung. Der einzige Workaround ist, wenn ich mein Profil 10 bis 15 mal neu lade (Zuletzt verwendetes Benutzerprofil öffnen), dann kann ich den "Befehlseditor" öffnen ohne das mir DNS 15 abstürzt. Wenn ich DNS 15 beende und anschließend wieder starte, muss ich die Prozedur wiederholen und mein Profil öfters laden, damit der "Befehlseditor" sich öffnet. Solange DNS 15 läuft und der "Befehlseditor" auf geht passt das auch den ganzen Tag, ich darf DNS 15 nur nicht schließen, denn dann beginnt alles von vorn. Einmal das Profil laden reicht irgendwie einfach nicht und ich weiß nicht warum. Selbst ein frisches Profil macht keinen Unterschied. Selbst wenn ich keine Befehle importiere und alles in DNS 15 auf Standard lasse, macht es keinen Unterschied.

Das Problem tritt übrigens auch mit DNS 11 nun auf, ein Wechsel wäre also irrelevant. Und ja, wahrscheinlich liegt der Fehler intern bei Windows, doch ich verstehe nicht, warum der "Befehlseditor" sich dann aber doch öffnet wenn ich nur oft genug mein Profil neu lade. Zudem habe ich mein System überprüft, sowohl den RAM, Treiber und auch sfc /scannow wurde mehrmals auf verschiedenen Laufwerken ausgeführt, mein Windows zeigt mir keinerlei Fehler oder korrupte Dateien an. Ebenso hab ich die Installation mit einem neuen Windows Benutzerkonto versucht, macht keinen Unterschied. Auch die Rechte des Profilordners sind ordnungsgemäß verteilt. Wie gesagt, an all dem kann es kaum liegen, da der "Befehlseditor" dann irgendwann ja doch startet, wenn das Profil oft genug geladen wurde.

Ich benötige den "Befehlseditor" nämlich mehr als alles andere in DNS, da ich eine körperliche Behinderung habe, noch dazu einen Gaming-Blog betreibe, muss ich regelmäßig Befehle zum Zocken erstellen, doch ohne "Befehlseditor" geht das natürlich nicht. Beziehungsweise, wenn das wieder normal laden würde. Ich weiß, sehr spezifisch, doch vielleicht kann mir irgendjemand helfen, ich wäre jedem sehr dankbar.

Hier noch mein System:

Windows 10 64bit
Phenom 8120 with eightcore 3,1Ghz
8 GB RAM
Gforce 970 with 4GB
Sennheiser GSP 350

Das Dragon Log füge ich hinzu wenn es jemand braucht.

2

Re: Spezifischer Fehler mit dem Befehlseditor

Spezifische Hinweise, die über das hinausgehen, was Sie schon versucht haben, fallen mir nicht ein. Von einem solchen Fehler innerhalb von Dragon habe ich jedenfalls noch nicht gehört (ich vermute, Sie meinen/verwenden Dragon Professional Individual 15).

Nur dieses vermag ich zu spekulieren: Ihr Rechner scheint ja schon etwas betagt zu sein. Der von Ihnen verwendete Prozessor ist laut Tante Google schon 2011 erschienen, richtig?
Mit AMD kenne ich mich nicht wirklich aus, es gab aber immer mal wieder Gerüchte, dass das nicht die Lieblings-Prozessoren des Drachen sind.

Wenn Sie sich keinen neuen Rechner kaufen wollen/können, wie wäre es mit einer kompletten Neuinstallation von Windows?

Dragon Legal Group 15.3, Win 10 Pro 1803, Office 2016 32-bit, SpeechMike Premium Air, i7-7700, 3,6 GHz, 64 GB RAM, 1TB SSD
Dragon für Mac 6.0.8, macOS 10.14, Office für Mac 2016, iMac Retina 5K 4,0 GHz i7-6700K, 32 GB RAM, 1TB SSD; MBP 2017 i5

3

Re: Spezifischer Fehler mit dem Befehlseditor

Schwieriger Fall. Die Möglichkeiten und Abgrenzungen zur Ursachen-Suche haben Sie ja weitgehend ausgeschöpft. Möglicherweise hilft die dragon.log weiter. Gibt es verwertbare Hinweise in der Windows-Ereignisprotokollierung? Starten Sie doch mal die nsbrowse.exe (im Dragon-Programmverzeichnis), OHNE DNS selbst zu starten. Was passiert dann?
Gruß, Pascal

4

Re: Spezifischer Fehler mit dem Befehlseditor

Nun, mit Onsche habe ich schon im No-Brainer Forum Bekanntschaft gemacht, und diverse Vorschläge unterbreitet. Mal sehen, ob er hier kooperativer ist.

DPI 15.3 (15.30.000.006) auf Windows 8.1 (64-bit)
SpeechMike Premium (LFH3500) mit Philips Device Control Center (3.0)
Intel i7 2600 QuadCore - 3.4 GHz - 8 MB L3-Cache - 6 GB RAM

5

Re: Spezifischer Fehler mit dem Befehlseditor

P.Roch schrieb:

Starten Sie doch mal die nsbrowse.exe (im Dragon-Programmverzeichnis), OHNE DNS selbst zu starten. Was passiert dann?
Gruß, Pascal

Hab ich schon versucht, war nämlich meine erste Idee. Macht aber leider keinen unterschied ob ich nsbrowse.exe separat öffne oder in Dragon. Weil das Fenster für den "Befehlseditor" kann man separat nicht öffnen außer wenn man sagt "neu", dann käme der "Befehlseditor" separat, dazu muss das Profil aber auch geladen werden.

R.Wilke schrieb:

Nun, mit Onsche habe ich schon im No-Brainer Forum Bekanntschaft gemacht, und diverse Vorschläge unterbreitet. Mal sehen, ob er hier kooperativer ist.

Eigentlich war ich doch kooperativ im KB-Forum, hab auch die log hochgeladen. Auf eines bin ich nicht eingegangen, muss ich zugeben, da ich selber noch einiges versucht habe. Und zwar auf ihre Frage hin, ob ich das auf einem zweiten Rechner testen könne. Leider nein, ich könnte alternativ nur einen virtuellen Rechner erstellen, allerdings funktioniert DNS soweit ich weiß nicht besonders gut in einer virtuellen Umgebung. Auf meinen letzten Beitrag im KB-Forum ist zudem ohnehin niemand drauf eingegangen. Weil auch dort habe ich geschrieben, das mein Workaround das "Profil öfters neu laden" ist, es hat aber niemand geantwortet.

Und wie gesagt, grundsätzlich öffnet sich ja der "Befehlseditor", doch nur wenn mein Profil oft genug geladen wird. Es ist fast so, als ob Dragon nicht auf Anhieb alle Daten aus dem Profil findet und reinlädt, erst wenn der Vorgang öfters wiederholt wird scheint alles drin zu sein. Die Festplatten haben wie gesagt keine Fehler, meine Betriebsplatte ist zudem eine SSD. Sämtliche anderen Anwendungen haben keinerlei Probleme und auch mein Windows 10 funktioniert ansonsten reibungslos, weshalb neu aufsetzen momentan ziemlich ungünstig wäre, deswegen versuche ich eine Lösung zu finden. Der Fehler ist zudem für mich auch neu, ich hatte das vorher noch nie. Dabei verwende ich DNS seit fast 10 Jahren.

Momentan lade ich gerade das Profil ständig neu, damit der Befehlseditor sich öffnet. Soll ich hier nochmals die Logdatei hochladen?

6

Re: Spezifischer Fehler mit dem Befehlseditor

Nun, unter anderem hatte ich Ihnen noch vorgeschlagen, es mal mit der Dragon-Leiste im modernen Stil zu probieren, da ich in dem Film gesehen habe, dass der Klassik-Modus eingestellt ist, und es wäre eine Kleinigkeit, das zu testen und sich dazu zu äußern.

Auf meinen letzten Beitrag im KB-Forum ist zudem ohnehin niemand drauf eingegangen. Weil auch dort habe ich geschrieben, das mein Workaround das "Profil öfters neu laden" ist, es hat aber niemand geantwortet.

Was wohl daran liegt, dass Ihr letzter Beitrag bei KnowBrainer danach geklungen hat, als hätten Sie die Lösung gefunden und würden keine weiteren Antworten erwarten.

Indessen hätte ich noch einen Tipp für Sie, auch wenn ich schon vorweg annehme: wahrscheinlich vergeblich. Es ist gut möglich, dass der RAM nicht in Ordnung ist, denn unerklärliches Dragon-Verhalten hängt oft damit zusammen. Aus eigener leidvoller Erfahrung kann ich berichten, dass man den RAM nicht zuverlässig mit Software überprüfen kann. Da hilft nur die physische Methode.

Wenn Sie etwas 8 GB RAM haben, sind es vermutlich zwei Speicherblöcke, wovon eventuell einer kaputt ist. Nehmen Sie einen davon raus und lassen den PC eine Zeitlang nur mit 4 GB laufen. Alles wird dann langsamer, aber wenn Dragon nicht mehr abstürzt, bauen Sie den herausgenommenen Block ein und testen damit, also auch wieder nur 4 GB. Auf jeden Fall werden Sie beim defekten Speicher sofort Fehlverhalten bemerken.

Nur auf dem Weg konnte ich mir mal helfen, nachdem Dragon sich monatelang zuvor merkwürdig verhielt, ich alles getestet habe, was ich bekommen konnte, und auch der Hersteller (das Gerät war noch unter Garantie) nichts finden konnte, oder wollte.

Dragon ist so extrem speicherintensiv, dass defekter Speicher immer oder meist im Zusammenhang mit Dragon auftritt, so dass man zwangsläufig annehmen muss, es liegt an Dragon.

DPI 15.3 (15.30.000.006) auf Windows 8.1 (64-bit)
SpeechMike Premium (LFH3500) mit Philips Device Control Center (3.0)
Intel i7 2600 QuadCore - 3.4 GHz - 8 MB L3-Cache - 6 GB RAM

7 Zuletzt bearbeitet von Onsche (30.01.2018 11:09:09)

Re: Spezifischer Fehler mit dem Befehlseditor

@R.Wilke

Das mit der Leiste hatte ich tatsächlich vergessen zu erwähnen, sry. Habe es aber natürlich auch getestet. Also eigentlich jede Darstellung von Dragon habe ich ausprobiert, war aber leider auch nicht das Problem.

An den RAM hatte ich allerdings auch schon gedacht. Ich überprüfte zwar bereits den RAM mit memtest, allerdings habe ich übersehen das ein Riegel immer erst raus muss. Weil memtest berechnet immer die Summe des Speichers, sind aber 2x4 RAM drinnen, so kann der eine Riegel den anderen überdecken bzw. die Summe verfälschen, stimmt.

Ich werde die Tage die einzelnen Riegel auch physisch testen, weil die Vermutung dass der Speicher was haben könnte hatte ich wie gesagt auch schon. Es wäre noch nicht einmal verwunderlich, ich besitze die Riegel schon recht lange, ein Defekt würde mich demzufolge nicht überraschen.

Ich werde dann Rückmeldung machen, danke erstmal.